3.14.2 Upgrade not working for me

Home Forums AdRotate for WordPress General Support 3.14.2 Upgrade not working for me

This topic contains 23 replies, has 4 voices, and was last updated by  Arnan de Gans 3 years, 7 months ago.

  • #11430

    schooladvice
    Badges:

    I updated the plugin today and now all my adds show the following in place of where the ad should be:

    echo adrotate_ad(52, true, 0, 0);

    I’ve tried deactivating and activating but no change. I am using the free version – if I get a positive solution for this I will by the single license version.

    Thanks for your help

    #11446

    Arnan de Gans
    Badges:

    That’s to do with the AdRotate caching setting.
    If you don’t have W3 Total Cache installed, disable caching support in AdRotate Settings.
    If you do have that plugin, clear the cache.

    Also make sure there is no warning about W3TC_DYNAMIC_SECURITY in AdRotate settings > Misc. If there is, follow the instruction there.

    #11464

    schooladvice
    Badges:

    Great Thank! That did the trick and as promised I have purchased a single user license.

    Michael

    #11466

    Arnan de Gans
    Badges:

    Nice, Thanks for your purchase!
    What did you do to solve the problem?

    #11468

    schooladvice
    Badges:

    I simply turned off cache support as you suggested and all worked as it should.
    Thanks again for you quick response and assistance.

    Installing the Pro ver now.

    Michael H

    #11897

    transfeo
    Badges:

    There is something wrong. I use W3 Total Cache and had the option “Check this box if you use W3 Total Caching on your site” checked. It stoped working and returned when I turned it off. Is the contrary it was suposed to do…

    #11926

    cvedovini
    Badges:

    Same problem here, followed https://ajdg.solutions/manuals/adrotate-manuals/caching-support/ to the letter and it still doesn’t work. Had to disable page caching entirely…

    #12075

    Arnan de Gans
    Badges:

    @transfeo & @cvedovini – and what didn’t work when you have the option enabled? What did you see?

    #12083

    cvedovini
    Badges:

    Hi,
    It happened the same thing as the poster, it went from working perfectly well to showing code, instead of the ads, after the upgrade (and W3TC was setup as explained in your post)

    Right now I had to turn off page caching for the ads to show up again

    #12263

    Arnan de Gans
    Badges:

    If it’s the same problem, the solution is in the posts in the topic – Obviously.
    If that doesn’t work you either didn’t follow the setup correctly or something else is wrong. Perhaps you simply need to clear the cache.

    #12282

    cvedovini
    Badges:

    except that I actually did apply that solution and it still didn’t work. I did exactly what’s indicated here: https://ajdg.solutions/manuals/adrotate-manuals/caching-support/

    #12286

    cvedovini
    Badges:

    the only difference with your post is that I use Memcached, not Disk

    #12288

    cvedovini
    Badges:

    I just re-enabled page caching, making sure late initialisation is enabled, the security hash is set and the checkbox for W3 Total Caching is enable in the AdRotate options, and this is what I get: http://vedovini.net/2015/10/using-the-wordpress-settings-api-with-network-admin-pages/ (right sidebar)

    #12338

    Arnan de Gans
    Badges:

    @cvedovini Since you’ve answered your own question/problem, I think we’re done here… 🙁

    #12342

    cvedovini
    Badges:

    @arnan don’t know what you’re talking about, it still doesn’t work, the code is showing instead of the ads

    #12344

    Arnan de Gans
    Badges:

    the only difference with your post is that I use Memcached, not Disk

    You didn’t follow the manual, hence it’s not working 😉

    #12346

    cvedovini
    Badges:

    here’s a screenshot of what I see, in case you don’t have the same: https://flic.kr/p/CSfeuJ

    I ma in Chrome incognito mode, with a non primed browser cache and to make sure I made a hard refresh before taking the screenshot

    #12348

    cvedovini
    Badges:

    Switched to Disk: Basic, emptied all caches, reloaded in a new incognito window, hard refresh and got the same result

    #12350

    cvedovini
    Badges:

    ok, I got it!

    I disabled W3TC page caching but let the option on in AdRotate to see what the plugin outputs and there was no <!– mfunc –> comment. The HTML minifier was stripping them. You need to make sure “mfunc” is in the list of ignored comment stems of the HTML minifier (you should add that to your post)

    Thanks for the help

    #12392

    Arnan de Gans
    Badges:

    In the W3 minifier?

Viewing 20 posts - 1 through 20 (of 24 total)

The topic ‘3.14.2 Upgrade not working for me’ is closed to new replies.

You may be interested in