Ad unit set to mobile only is appearing on desktop

Home Forums AdRotate for WordPress General Support Ad unit set to mobile only is appearing on desktop

This topic contains 8 replies, has 2 voices, and was last updated by  Arnan de Gans 2 years, 9 months ago.

  • #21705

    Victor
    Badges:

    I have two ad units, one which I want to appear only on desktop and the other only on mobile. But the one set for mobile only is still appearing in desktop. Here are the settings on the one that should only appear on mobile:

    Settings for mobile only unit

    In my template I have both ad units, and I assumed that the adrotate settings would display one of them on mobile and the other on desktop:

          <?php echo adrotate_ad(96); ?>
          <?php echo adrotate_ad(112); ?>
    #21713

    Victor
    Badges:

    Does this feature only work if using groups and not for individual ads?

    If so, how do I set each of two ads so one appears 100% on desktop and the other 100% on mobile? I’m concerned that if I set each to say level 6 and there are two ads in the group that I’ll only get 50% fill on both desktop and mobile.

    Thanks

    #21715

    Victor
    Badges:

    OK, more testing.

    If I put the ad units into my template individually as shown in my initial post, both ad units load on both desktop and on mobile.

    If I put the ad group into my template (which does have “Enable mobile support” checked) then I get NO ads at all on desktop, but I do get the mobile only ad on mobile. Here is the message I get on desktop when I use this method:

    <!– Either there are no banners, they are disabled or none qualified for this location! –>

    #21753

    Arnan de Gans
    Badges:

    Looks like your desktop advert is not set up correctly then 😉
    Something in that advert prevents it from showing.

    And yes, as noted on the feature in the advert, you need to put the adverts in a group for those features to work, otherwise you can’t alternate between adverts.

    #21758

    Victor
    Badges:

    No, that is not correct, otherwise when I put in the individual ad unit adrotate code for both it would not display either, and when I do that the ad code loads on both desktop and mobile with no problem. Is something below not configured correctly?

    Group settings:
    Adrotate Group Settings

    Desktop only ad unit settings:
    Desktop only ad unit settings

    Mobile only ad unit settings:
    Mobile only ad unit settings

    The js ad code for each unit is exactly what I was using directly in my template (and working) before I moved them to adrotate.

    #21890

    Victor
    Badges:

    Hello?

    #22085

    Arnan de Gans
    Badges:

    Both adverts need to be in a group for the mobile option to work.
    This is noted next to the checkboxes and in the manual.
    Check the manual for details – https://ajdg.solutions/manuals/adrotate-manuals/mobile-adverts/

    If you don’t select any operating systems the advert may not show of-course.

    #22102

    Victor
    Badges:

    I jut showed you all the settings, pointing me back to that page doesn’t help. Did you not look at my screenshares instead of just assuming user cluelessness?

    I ended up having to set up two different ad groups, one for mobile and one for desktop and putting both adgroups into my template. Seems to me your plugin can’t have a desktop ad and a mobile ad in it and have one load in mobile and the other in desktop.

    #22130

    Arnan de Gans
    Badges:

    The whole idea is to have 1 group with both types so the group can alternate adverts.
    If you do not select a OS for your tablet/desktop advert then the advert probably can not show, as I pointed out.

    Obviously I looked at your screenshots and the only odd thing I saw was the no-os-selection.

    If none of that seems to work, make sure you do not have a caching plugin/setup that hinders things.

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Ad unit set to mobile only is appearing on desktop’ is closed to new replies.

You may be interested in