AdRotate plugin not loaded correctly

Home Forums AdRotate for WordPress Bug Reports AdRotate plugin not loaded correctly

  • #166735


    Hi there!

    Yesterday I update to the version 5.10 of AdRotate and this morning I get the message from my web: “This plugin has not loaded correctly and is paused during recovery mode”.
    I have to deactivate the plugin in order to get the web accesible with the negative consequences it has for advertisers, banners are not displayed.
    The complete message is:
    “Se ha producido un error del tipo E_ERROR en la línea 134 del archivo /home/ajdofir/noticierotextilnet/wp-content/plugins/adrotate-pro/library/update-api.php. Mensaje de error: Uncaught Error: Attempt to modify property “response” on bool in /home/ajdofir/noticierotextilnet/wp-content/plugins/adrotate-pro/library/update-api.php:134 Stack trace: #0 /home/ajdofir/noticierotextilnet/wp-includes/class-wp-hook.php(309): adrotate_get_update_information(false) #1 /home/ajdofir/noticierotextilnet/wp-includes/plugin.php(191): WP_Hook->apply_filters(false, Array) #2 /home/ajdofir/noticierotextilnet/wp-includes/option.php(1922): apply_filters(‘pre_site_transi…’, false, ‘update_plugins’) #3 /home/ajdofir/noticierotextilnet/wp-includes/update.php(290): get_site_transient(‘update_plugins’) #4 /home/ajdofir/noticierotextilnet/wp-includes/class-wp-hook.php(307): wp_update_plugins(”) #5 /home/ajdofir/noticierotextilnet/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters(NULL, Array) #6 /home/ajdofir/noticierotextilnet/wp-includes/plugin.php(476): WP_Hook->do_action(Array) #7 /home/ajdofir/noticierotextilnet/wp-admin/admin.php(385): do_action(‘…’) #8 /home/ajdofir/noticierotextilnet/wp-admin/plugins.php(10): require_once(‘/home/ajdofir/n…’) #9 {main} thrown”

    Is there something I can do?

    Please help!

    Thanks in advance!

    Diego from


    Arnan de Gans

    Please post a ticket through if you want to help test a version that probably/hopefully fixes this. Otherwise wait for the update.



    fatal error…

    /home/xxxxxxx/public_html/wp-content/plugins/adrotate-pro/library/update-api.php. Poruka greške: Uncaught Error: Attempt to modify property “response” on bool in /home/xxxxxxx/public_html/wp-content/plugins/adrotate-pro/library/update-api.php:134
    Stack trace:
    #0 /home/xxxxxxx/public_html/wp-includes/class-wp-hook.php(310): adrotate_get_update_information(false)
    #1 /home/xxxxxxx/public_html/wp-includes/plugin.php(205): WP_Hook->apply_filters(false, Array)
    #2 /home/xxxxxxx/public_html/wp-includes/option.php(1948): apply_filters(‘pre_site_transi…’, false, ‘update_plugins’)
    #3 /home/xxxxxxx/public_html/wp-includes/update.php(901): get_site_transient(‘update_plugins’)
    #4 /home/xxxxxxx/public_html/wp-includes/admin-bar.php(1083): wp_get_update_data()
    #5 /home/xxxxxxx/public_html/wp-includes/class-wp-hook.php(308): wp_admin_bar_updates_menu(Object(WP_Admin_Bar))
    #6 /home/xxxxxxx/public_html/wp-includes/class-wp-hook.php(332): WP_Hook->apply_filters(NULL, Array)
    #7 /home/xxxxxxx/public_html/wp-includes/plugin.php(565): WP_Hook->do_action(Array)
    #8 /home/xxxxxxx/public_html/wp-includes/admin-bar.php(95): do_action_ref_array(‘admin_bar_menu’, Array)
    #9 /home/xxxxxxx/public_html/wp-includes/class-wp-hook.php(308): wp_admin_bar_render(”)
    #10 /home/xxxxxxx/public_html/wp-includes/class-wp-hook.php(332): WP_Hook->apply_filters(”, Array)
    #11 /home/xxxxxxx/public_html/wp-includes/plugin.php(517): WP_Hook->do_action(Array)
    #12 /home/xxxxxxx/public_html/wp-admin/admin-header.php(267): do_action(‘in_admin_header’)
    #13 /home/xxxxxxx/public_html/wp-admin/edit.php(407): require_once(‘/home/dalmacija…’)
    #14 {main}



    Updated yesterday as well …. Throws an error on every site



    here it is the Pro version which gives an error



    Rolled back to version 5.9.1.

    Version 5.10.1.dont trow any error but Post Injection Ads dont working


    I believe I am having the same problem. When AdRotate Pro is active, I receive a critical error in my admin panel of WP.

    I have submitted a ticket.



    Arnan de Gans

    Version 5.10.2 fixes the issue. Check the blog for details on how to update.

    If you need help with installing the update let me know here.
    If you don’t know how to upload plugins please include a WordPress admin login and (s)FTP login so I can do the update for you.


    Arnan de Gans

    Moved to bugreports.



    Unfortunately, it works if there is only one ad in text. It doesn’t work with multiple ads. It only shows one sometimes two but never all 3 or 4. I reverted back to version 5.9.1 until the problem is solved.

    After i rollback to 5.9.1 it trow this error:

    thrown in /home/xxxxxxxx/public_html/wp-content/plugins/w3-total-cache/PgCache_ContentGrabber.php(1905) : eval()’d code on line 1
    [13-Jan-2023 02:58:29 UTC] PHP Fatal error: Uncaught Error: Call to undefined function adrotate_group_post_inject() in /home/xxxxxxxx/public_html/wp-content/plugins/w3-total-cache/PgCache_ContentGrabber.php(1905) : eval()’d code:1
    Stack trace:
    #0 /home/xxxxxxxx/public_html/wp-content/plugins/w3-total-cache/PgCache_ContentGrabber.php(1905): eval()
    #1 [internal function]: W3TC\PgCache_ContentGrabber->_parse_dynamic_mfunc(Array)
    #2 /home/xxxxxxxx/public_html/wp-content/plugins/w3-total-cache/PgCache_ContentGrabber.php(1876): preg_replace_callback(‘~<!–\\s*mfunc\\s…’, Array, ‘\n<!DOCTYPE html…’)
    #3 /home/xxxxxxxx/public_html/wp-content/plugins/w3-total-cache/PgCache_ContentGrabber.php(394): W3TC\PgCache_ContentGrabber->_parse_dynamic(‘\n<!DOCTYPE html…’)
    #4 /home/xxxxxxxx/public_html/wp-content/plugins/w3-total-cache/PgCache_ContentGrabber.php(2075): W3TC\PgCache_ContentGrabber->process_cached_page_and_exit(Array)
    #5 /home/xxxxxxxx/public_html/wp-includes/class-wp-hook.php(308): W3TC\PgCache_ContentGrabber->delayed_cache_print(”)
    #6 /home/xxxxxxxx/public_html/wp-includes/class-wp-hook.php(332): WP_Hook->apply_filters(NULL, Array)
    #7 /home/xxxxxxxx/public_html/wp-includes/plugin.php(517): WP_Hook->do_action(Array)
    #8 /home/xxxxxxxx/public_html/wp-settings.php(617): do_action(‘init’)
    #9 /home/xxxxxxxx/public_html/wp-config.php(62): require_once(‘/home/xxxxxxxx…’)
    #10 /home/xxxxxxxx/public_html/wp-load.php(50): require_once(‘/home/xxxxxxxx…’)
    #11 /home/xxxxxxxx/public_html/wp-blog-header.php(13): require_once(‘/home/xxxxxxxx…’)
    #12 /home/xxxxxxxx/public_html/index.php(17): require(‘/home/xxxxxxxx…’)
    #13 {main}
    thrown in /home/xxxxxxxx/public_html/wp-content/plugins/w3-total-cache/PgCache_ContentGrabber.php(1905) : eval()’d code on line 1



    error are stoped when i disable memcached but ads still not showing



    the error returned again


    Arnan de Gans

    None of those errors seem related to AdRotate, but instead to W3 Total Caching.

    The post injection is working mostly fine and does not give errors, but something in the logic is not correct. A fix is being tested.


    Arnan de Gans

    All known issues to AdRotate Pro have been addressed and fixed in yesterdays update version 5.10.3.
    If you have any other issues or you found something new please let me know in a support ticket.

    For AdRotate Banner Manager I’ve just released version 5.10.1 fixing some smaller issues – Version 5.10.1 is available now – More info here:



    have same problem with intext ads. Rolled back to version 5.9.1.


    Arnan de Gans

    What’s not working?



    i wrote u support ticket



    In each news we have 4-5 ads. After the updates, only one ad is shown in the news feed, and it’s random. The plugin does not show all ads.

    I have sent you the access data.

    I note that everything works on version 5.9.1.

Viewing 18 posts - 1 through 18 (of 18 total)

The topic ‘AdRotate plugin not loaded correctly’ is closed to new replies.

You may be interested in