Ads not showing, again.

Home Forums AdRotate for WordPress Adverts and Banners Ads not showing, again.

  • #152903

    JonathanR
    Badges:

    So we’ve been using AdRotate Pro for quite a long while and everyone and a while the ads won’t show, which is usually because I’ve optimized the WordPress database but then show up again a day or two later. But lately they haven’t been showing at all for an unknown period of time, possibly a week or more. Obviously this is a problem of lost revenue and angry clients.

    Web work is always a pain because whether something works or doesn’t it seems I never know why.

    I’ve tried to troubleshoot by:
    – Clearing Cache
    – Deactivating my caching plug-in (Litespeed Cache)
    – Clearing Cloudflare cache
    – Deactivating Clearfy WordPress optimization plugin
    – Creating new Ad Placements
    – Using all the tools in AdRotate’s maintenance tab
    – Looked for answers to similar issues in the forums but they didn’t help

    I have not yet tried to completely remove and reinstall the plug-in as I didn’t want to have to redo everything if I didn’t have to.

    So far nothing works. I just can’t get the ads to show up.

    #152905

    Arnan de Gans
    Badges:

    Sounds like a caching conflict, and seeing that you use 2 together and ALSO use an optimizer… Not good. One is plenty, and even that should be optional.
    I don’t use caching on this site for example, just an optimizer for Javascript.

    If you throw out Litespeed and just use Cloudflare’s thing it may work.
    Litespeed doesn’t support fragmented caching which AdRotate needs.
    However, AdRotate has support for Borlabs Cache and W3 Total Cache. Check out this manual to see how to set up the plugins for that to work; https://ajdg.solutions/support/adrotate-manuals/caching-support/ Personally I prefer Borlabs cache (https://borlabs.io) as it’s much easier to set up.

    If you must have a caching plugin as well, perhaps you should not blame your website but your hosting and get better hosting.

    #153026

    JonathanR
    Badges:

    I’ve uninstalled LiteSpeed Cache. We’ll see in a day or so whether or not that actually fixed anything.

    #153098

    JonathanR
    Badges:

    Not sure what happened but my last post disappeared.

    Uninstalling LiteSpeed Cache did nothing.

    I also put Cloudflare in maintenance mode and cleared the cache, along with disabling and reenabling AdRotate. That also didn’t help.

    This all worked before using the same configuration.

    http://www.montanaseniornews.com & idahoseniorindependent.com are the sites in question.

    #153099

    JonathanR
    Badges:

    I notice if I place the short code for a Google ad in a post, it shows, but not the ones in groups throughout my Elementor controlled theme I’ve had working previously. Nor do the manually done ads using static images whether using the shortcode or not.

    #153103

    Arnan de Gans
    Badges:

    The ‘missing’ adverts are fine in your dashboard?
    No errors/notices?
    Does the preview work when you edit them?

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

You may be interested in