After update to Pro ads are not displayed anymore

Not one for queueing up? Get faster support with AdRotate Pro!
The forum is checked a few times per week. With AdRotate Pro you can get answers faster using email support.
More private, more direct and usually a solution within a day! Learn more »

Home Forums AdRotate for WordPress Installation and Setup After update to Pro ads are not displayed anymore

This topic contains 5 replies, has 3 voices, and was last updated by  Arnan 4 months, 2 weeks ago.

  • #41272

    bullmarkets
    Badges:

    – Which version of the plugin do you have?
    4.10.1 Pro version

    – Which WordPress version do you use?
    4.9.1

    – Is your WordPress a multisite/networked installation?
    Single site

    – Do you use a caching plugin? Which one?
    No

    #41274

    bullmarkets
    Badges:

    Ok, my initial post got lost, here it is again:

    Hello,

    I have searched for similar problems and the closest problem I could find was probably:

    https://ajdg.solutions/forums/topic/switched-to-adrotatepro-ads-are-not-displayed/

    After installation of Pro version the ads wouldnt display anymore. With the same error message in the HTML code as above. When deactivating pro and changing to the free version, the ads become visible again.

    After looking in the error file I noticed that several columns in the database could not be found. For example:

    [:error] [pid 13675] [client …] WordPress-Datenbank-Fehler Unknown column ‘day_sun’ in ‘wp_adrotate_schedule’ f\xc3\xbcr Abfrage ALTER TABLE wp_adrotate_schedule ADD autodelete char(1) NOT NULL default ‘N’ AFTER day_sun; von require_once(‘wp-admin/admin-header.php’), do_action(‘admin_notices’), WP_Hook->do_action, WP_Hook->apply_filters, adrotate_notifications_dashboard, adrotate_check_upgrade, adrotate_database_upgrade, adrotate_add_column, referer: …

    Here is an overview for the available columns in this case:

    show columns from wp_adrotate_schedule;
    +—————-+———————–+——+—–+———+—————-+
    | Field | Type | Null | Key | Default | Extra |
    +—————-+———————–+——+—–+———+—————-+
    | id | mediumint(8) unsigned | NO | PRI | NULL | auto_increment |
    | name | varchar(255) | NO | | | |
    | starttime | int(15) unsigned | NO | | 0 | |
    | stoptime | int(15) unsigned | NO | | 0 | |
    | maxclicks | int(15) unsigned | NO | | 0 | |
    | maximpressions | int(15) unsigned | NO | | 0 | |
    | spread | varchar(5) | NO | | N | |
    +—————-+———————–+——+—–+———+—————-+
    7 rows in set (0.00 sec)

    It seems to me that the DB has not been properly updated with the upgrade on PRO version. How can I fix the issue? Would like to upgrade to Pro again.

    Thanks,
    Andre

    #41625

    Arnan
    Badges:

    After updating, did you click the big “finish update” button at the top of your dashboard? If not, click it.

    If the button isn’t there – Go to Settings > Maintenance, check the database versions.
    You can, if you need to, run the updater from there as well.

    #43692

    popimp3069
    Badges:

    I used this Javascript code in the free versions of AdRotate. I just upgraded to Pro and now it doesn’t work. I cannot edit the Adcode or view it at all, and the ads no longer display. Any help is appreciated. Thanks

    var images = [], 
    index = 0;
    
    images[0] = "<a href='http://brazoriacountytx.gov/departments/parks-department/san-luis-pass'><img src='http://www.saltwater-recon.com/wp-content/uploads/2016/12/saltwater-recon-brazoria-county-300x300.png' alt='Brazoria County' /></a>";
    
    images[1] = "<a href='http://www.galvestonyachtservice.com'><img src='http://www.saltwater-recon.com/wp-content/uploads/2016/12/saltwater-recon-galveston-yacht-service-300x300.png' alt='Galveston Yacht Service' /></a>";
    
    images[2] = "<a href='http://www.seabrooksailingclub.org'><img src='http://www.saltwater-recon.com/wp-content/uploads/2017/06/Saltwater-Recon-Seabrook-Sailing-Club-300.png' alt='Hall of Fame' /></a>";
    
    index = Math.floor(Math.random() * images.length);
    document.write(images[index]);
    //done
    
    #43694

    popimp3069
    Badges:
    var images = [], 
    index = 0;
    
    images[0] = "<a href="//brazoriacountytx.gov/departments/parks-department/san-luis-pass'"><img src="//www.saltwater-recon.com/wp-content/uploads/2016/12/saltwater-recon-brazoria-county-300x300.png'" alt="'Brazoria"></a>";
    
    images[1] = "<a href="//www.galvestonyachtservice.com'"><img src="//www.saltwater-recon.com/wp-content/uploads/2016/12/saltwater-recon-galveston-yacht-service-300x300.png'" alt="'Galveston"></a>";
    
    images[2] = "<a href="//www.seabrooksailingclub.org'"><img src="//www.saltwater-recon.com/wp-content/uploads/2017/06/Saltwater-Recon-Seabrook-Sailing-Club-300.png'" alt="'Hall"></a>";
    
    index = Math.floor(Math.random() * images.length);
    document.write(images[index]);
    //done
    
    #43805

    Arnan
    Badges:

    What do you mean with you can’t edit your adverts? The advert overlays the edit screen?
    If so, try disabling the Live Preview option in Settings.

    Adverts not displaying can be a bunch of things. AdRotate and AdRotate Pro use the exact same code to output their adverts, so if it works in one, it’ll work in the other as well.

    Please check your advert settings for errors. Also check yoru servers error_log file for anything mentioning AdRotate. Anything is interesting.

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘After update to Pro ads are not displayed anymore’ is closed to new replies.