E_ERROR was caused in line 81

HomeForumsAdRotate for WordPressBug ReportsE_ERROR was caused in line 81

  • #121093

    Meryl Moss
    Badges:

    Hi,

    WordPress pushed a notification about this error on Line 81 of update-api.php. I just upgraded from 5.8.8 to 5.8.9. Does the latest update resolve this error? It’s not listed in the changelog, so I just wanted to be sure by checking in here on the support forum. Please let me know. Thanks.

    Error Details
    =============
    An error of type E_ERROR was caused in line 81 of the file /nas/content/live/booktribcom/wp-content/plugins/adrotate-pro/library/update-api.php. Error message: Uncaught Error: Cannot use object of type WP_Error as array in /nas/content/live/booktribcom/wp-content/plugins/adrotate-pro/library/update-api.php:81
    Stack trace:
    #0 /nas/content/live/booktribcom/wp-content/plugins/adrotate-pro/library/update-api.php(139): adrotate_update_check()
    #1 /nas/content/live/booktribcom/wp-includes/class-wp-hook.php(289): adrotate_get_update_information(Object(stdClass))
    #2 /nas/content/live/booktribcom/wp-includes/plugin.php(212): WP_Hook->apply_filters(Object(stdClass), Array)
    #3 /nas/content/live/booktribcom/wp-includes/option.php(1899): apply_filters(‘site_transient_…’, Object(stdClass), ‘update_plugins’)
    #4 /nas/content/live/booktribcom/wp-admin/includes/update.php(383): get_site_transient(‘update_plugins’)
    #5 /nas/content/live/booktribcom/wp-content/plugins/all-in-one-seo-pack-pro/app/Common/Tools/SystemStatus.php(286): get_plugin_updates()
    #6 /nas/content/live/booktribcom/wp-content/plugins/all-in-one-seo-pack-pro/app/Common/Tools/SystemStatus.php(19): AIOSEO\Plugin\Common\

    #121097

    That should indeed be fixed in 5.8.9 onwards.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

You may be interested in