Post injections not working

Trouble updating AdRotate Professional to the latest version?

If your license is not expired and you are having trouble with updates for AdRotate Professional I want to hear from you!
Known issues; The update will not install or no update is visible in your dashboard.
Affected versions; Most versions of AdRotate Professional since December 2019.

Click here for the solution - AdRotate Pro update not working or not offered.

Home Forums AdRotate for WordPress General Support Post injections not working

  • #105755

    tgl
    Badges:

    I have been testing a post injection ad after the 4th paragraph of a category and I can’t figure out why it won’t display the ad.

    This is the list of posts for the category:

    https://harnessracingupdate.com/ask-the-guru/

    I double checked the ad, it was previously running in a different ad group so all I did was change the group it was assigned to:

    https://www.screencast.com/t/3lCiWETKRS

    When you are looking at any of those single posts, there are 4 ad groups running:

    Header (right below the header)
    Before & After Content (before and after the post content)
    Injected (after 4th paragraph)
    Footer (right above footer)

    Header, injected and footer are all showing ads, just that missing injected group.

    #106166

    tgl
    Badges:

    Still no luck getting the category injection ads to work . . .

    #106192

    Arnan de Gans
    Badges:

    Seems to me the injection works just fine. But there are no ads in the group to display. See screenshot: https://disk.stor.fit/index.php/s/JaHrmnb9XTEdMQW

    So make sure you have at least one valid/working advert in the group.

    #106195

    tgl
    Badges:

    I extended the ad a week, try this post in the same category:

    https://harnessracingupdate.com/2020/06/12/does-a-mares-number-of-foals-impact-yearling-buying-and-do-a-horses-eyes-work-separately/

    The two most recent posts in that category I have manually placed in the post as the injection wasn’t displaying the ad.

    That ad is valid for that group/category:

    https://www.screencast.com/t/37hlSWsf675Y

    #106203

    Arnan de Gans
    Badges:

    But it still says:
    <!-- Error, Ad (n/a) is not available at this time due to schedule/budgeting/geolocation/mobile restrictions! -->
    Where you want the advert to show up (after the 4th paragraph).

    So there is still no valid advert in the group 😉
    You can see this for yourself by looking at the page source.

    #106208

    tgl
    Badges:

    I am not sure which page source you are looking at:

    https://www.screencast.com/t/gsfpxfvaV

    The text you referenced doesn’t appear in my page source.

    #106315

    tgl
    Badges:

    When you say “it” still says . . . can we add some context or at least a noun to that sentence?

    I searched the page source and I don’t see any text matching

    <!– Error, Ad (n/a) is not available at this time due to schedule/budgeting/geolocation/mobile restrictions! –>

    Are you using a third-party tool or Chrome extension?

    #106333

    Arnan de Gans
    Badges:

    “it” is obviously refers to your website…
    https://harnessracingupdate.com/2020/06/12/does-a-mares-number-of-foals-impact-yearling-buying-and-do-a-horses-eyes-work-separately/

    As you could in my earlier linked screenshot it said the advert is not available.
    The HTML comment showed (and still does) after the 4th paragraph.

    Just inspect the content text and look for it. No special tools required.

    #106345

    tgl
    Badges:

    This earlier screenshot?

    https://www.screencast.com/t/nDGLS3gl

    I inspected the source file and the text you say should be in there, is not in there.

    The plugin is not doing what it’s supposed to do, maybe we could do some troubleshooting and find out why that is?

    #106351

    Arnan de Gans
    Badges:

    Fine, then we’re not looking at the same source.
    I see it. Post Injection works.

    The thing that seems to be missing from it is the advert. Make sure there is an advert in that group and that the advert is not expired.
    If you use caching, clear the cache, perhaps we’re looking at an older version of the page.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

You may be interested in