Post/Page injection is not working

Home Forums AdRotate for WordPress Groups Post/Page injection is not working

This topic contains 21 replies, has 3 voices, and was last updated by  economides 5 days, 18 hours ago.

  • #86627

    perceptinfotech
    Badges:

    Hello,

    In my wordpress site I have installed AdRotate Pro version (4.16). wordpress version is (5.2.3)

    https://www.luvcyprus.com/

    While creating the group there is an option to show advert banner in a specific post or page with position. I set them but can not see that banners in the front side.

    I guess there is some issue with it.

    Also I have a licence keys so please let me know how to generate premium support if I would needed.

    Hope for your quick response.

    Thank you.

    #86658

    Arnan de Gans
    Badges:

    Does the advert/group show up when you use a shortcode instead?

    This account does not have AdRotate Pro. So no premium support.
    Unless you got AdRotate Pro on a different account.

    #86943

    perceptinfotech
    Badges:

    Single Advert show up when I used a shortcode but group shortcode didn’t work either.
    Also in a widget group widget didn’t work.

    Yes, My client has purchased it but they don’t have login details right now so I used another account to generate support.

    #87055

    Arnan de Gans
    Badges:

    Start with updating to a newer version. The latest version is 5.5.1.
    It’s likely that your problem goes away with the newer version.

    Or, if you prefer, have me do the update, I can do so for a small fee – https://ajdg.solutions/product/adrotate-update/.
    Usually this can be done within a day or two. Please check the product page for details.

    #87233

    economides
    Badges:

    Ok thanks. I will check it with my client and get back to you soon.

    #87262

    Arnan de Gans
    Badges:

    Great 🙂 Hopefully updating will fix it.

    #87615

    economides
    Badges:

    I have updated to latest version of a plugin, but still, face the same issue of post/page injection.

    Can you please check it now?

    #87617

    economides
    Badges:

    Yes, the Updated version is 5.5, not 5.5.1.

    So if it needs 5.5.1 then can you provide me that version?

    #87645

    Arnan de Gans
    Badges:

    The latest version of AdRotate Professional is 5.5. AdRotate Banner Manager is at 5.5.1.
    If you’ve updated in the last few days you’re on the latest version.

    Commonly if adverts aren’t showing up there is an adblocker hindering things.
    Do you have adblockers active? If so, try disabling them and see if the advert shows up then.
    https://ajdg.solutions/support/adrotate-manuals/configure-adblockers-for-your-own-website/

    When you edit the advert, does the preview work?

    #87704

    economides
    Badges:

    No, Live preview does not work when I edit advert. Once I saved the change and then open advet agian I can see the change in preview.

    Also whenever I add a page for page injection in the group, in front error showing of – The site is experiencing technical difficulties.

    Shortcode for the group is also not working while shortcode for a single advert is working.

    When I tried to add a shortcode for group it even doesn’t let page to save or update.

    Note: I don’t have this – adblockers active thing installed in the browser, So I don’t think so it can be the problem

    #87810

    Arnan de Gans
    Badges:

    So then previews work.

    The technical difficulties bit are server errors, you probably received an email or two with the specific error in it…

    If there was no email, check your servers error_log file to see it. Anything mentioning AdRotate is interesting.

    What’s the error?

    #88164

    economides
    Badges:

    I checked in the admin email, and we did not receive any email related to it.
    (Also can you confirmed it that email will send to admin email only or to some other? Also in plugin admin email is set.)

    Server person will check soon log file.

    Is there any other proper solution you can suggest us ? As it’s been so many days we are facing this issue.

    And now I have to show add banners in my site.

    #88420

    economides
    Badges:

    Waiting for your response…!!

    #88446

    economides
    Badges:

    Hello,

    My client is very disappointed now and so am I too. We need to have some solution for this issue. Please provide some solution for that so we can go further with our banners.

    Hoping for your quick response now..!!
    Thank you.

    #88463

    Arnan de Gans
    Badges:

    Did you check the servers error_log yet? There were errors…

    Please check your servers error_log file for errors.
    The error_log file can usually be found in your hosting dashboard.
    Anything mentioning AdRotate is interesting.

    #88496

    economides
    Badges:

    we don’t have a hosting dashboard

    its just a linux VM with wordpress installed directly

    But I could find 1 log file in root of my ftp and in that there are some logs related to adrotate and it’s something like this (These are some lines I am sending)

    [11/Oct/2019:10:28:48 +0300] "GET /wp-content/plugins/adrotate-pro/library/raphael-min.js?ver=5.2.3 HTTP/1.1" 200 32108 "https://www.luvcyprus.com/wp-admin/admin.php?page=adrotate-groups" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.113 Safari/537.36"
    
    [11/Oct/2019:10:28:48 +0300] "GET /wp-content/plugins/adrotate-pro/library/textatcursor.js?ver=5.2.3 HTTP/1.1" 200 1199 "https://www.luvcyprus.com/wp-admin/admin.php?page=adrotate-groups" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.113 Safari/537.36"
    
    [11/Oct/2019:10:28:48 +0300] "GET /wp-content/plugins/adrotate-pro/library/jquery.adrotate.tablesorter.js?ver=5.2.3 HTTP/1.1" 200 1058 "https://www.luvcyprus.com/wp-admin/admin.php?page=adrotate-groups" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.113 Safari/537.36"
    
    [11/Oct/2019:10:28:48 +0300] "GET /wp-content/plugins/adrotate-pro/library/elycharts.min.js?ver=5.2.3 HTTP/1.1" 200 19260 "https://www.luvcyprus.com/wp-admin/admin.php?page=adrotate-groups" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.113 Safari/537.36"
    
    [11/Oct/2019:10:29:18 +0300] "POST /wp-admin/admin.php?page=adrotate-groups HTTP/1.1" 302 454 "https://www.luvcyprus.com/wp-admin/admin.php?page=adrotate-groups&view=edit&group=2" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.113 Safari/537.36"
    
    [11/Oct/2019:10:29:18 +0300] "GET /wp-admin/admin.php?page=adrotate-groups&status=201 HTTP/1.1" 200 21734 "https://www.luvcyprus.com/wp-admin/admin.php?page=adrotate-groups&view=edit&group=2" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.113 Safari/537.36"

    Please check it and if it’s not correct log file I am checking then tell me log file path if you know for my server.

    Hope it would help to get the problem and find a solution now.
    Waiting for your quick response.

    #88534

    Arnan de Gans
    Badges:

    That looks like an access log.
    Every server has a error_log, it’s usually next to the access_log.
    This is a standardized process, so unless someone deliberately disabled logs (which is dumb) there are logs. If you don’t know where to get them ask your server administrator.

    Also – There is no point in ALSO emailing everything you post here. It only clutters my inbox and slows down support to you. If things go to slow for you, then provide the information I ask for so we can proceed with the issue. If you read back, I asked for the errors you mentioned on the 7th. It’s now the 11th and you’ve said nothing that helps the issue along. So in effect I’ve been waiting for 4 days now. The slow going is all yours.

    #88590

    economides
    Badges:

    I finally could find something with error_log file,the error is as below

    I added post/page injection in privacy policy page –

    PHP Fatal error: Uncaught Error: Call to undefined method Mobile_Detect::isTablet() in /var/www/html/luvcyprus.com/wp-content/plugins/adrotate-pro/adrotate-functions.php:131\nStack trace:\n#0 /var/www/html/luvcyprus.com/wp-content/plugins/adrotate-pro/adrotate-output.php(104): adrotate_is_tablet()\n#1 /var/www/html/luvcyprus.com/wp-content/plugins/adrotate-pro/adrotate-output.php(409): adrotate_group(2)\n#2 /var/www/html/luvcyprus.com/wp-includes/class-wp-hook.php(286): adrotate_inject_posts('<h2>Privacy Pol...')\n#3 /var/www/html/luvcyprus.com/wp-includes/plugin.php(208): WP_Hook->apply_filters('<h2>Privacy Pol...', Array)\n#4 /var/www/html/luvcyprus.com/wp-includes/formatting.php(3709): apply_filters('the_content', '<h2>Privacy Pol...')\n#5 /var/www/html/luvcyprus.com/wp-includes/class-wp-hook.php(286): wp_trim_excerpt('<h2>Privacy Pol...', Object(WP_Post))\n#6 /var/www/html/luvcyprus.com/wp-includes/plugin.php(208): WP_Hook->apply_filters('', Array)\n#7 /var/www/html/luvcyprus.com/wp-includes/post-template.php(419): apply_filters(' in /var/www/html/luvcyprus.com/wp-content/plugins/adrotate-pro/adrotate-functions.php on line 131, referer: https://www.luvcyprus.com/

    I hope it would be helpful to you.

    And will keep that email thing in mind.

    Thank you.

    #88604

    Arnan de Gans
    Badges:

    That’s the only error?
    As far as I can tell, the only reason the function could be missing like that is if the file is missing.

    Make sure all files are in the right place. And that the plugin is up-to-date.
    It may be easier to just delete the adrotate-pro folder and upload a new copy (from a new download).
    You can follow the manual steps here to do so: https://ajdg.solutions/support/adrotate-manuals/upgrade-adrotate-pro-to-a-newer-version/

    If this doesn’t work I’m not sure what else to advise you.
    I can take a look at the setup myself, or re-install the update for you.
    I provide a service for that kind of thing – More information about that can be had here: https://ajdg.solutions/product/adrotate-update/.

    #88631

    economides
    Badges:

    I had updated to latest version when you first suggested me.. But it didn’t work.

    I once again tried to update with latest version and installed it, and guess what it works like a charm..!!

    Now everything is working fine. Will let you know if I face any issue in future.

    Sorry for some inconvenience.
    You’re great.

    Thanks for you support.

Viewing 20 posts - 1 through 20 (of 22 total)

You must be logged in to reply to this topic.

You may be interested in