There was an error loading the page.

Home Forums AdRotate for WordPress General Support There was an error loading the page.

  • #94871

    Hi. I moved my website to a new server and did all the relevant updates. Since I am not able to add any new “adds”. Follwing message appears: “There was an error loading the page. Please try again by reloading the page via the menu on the left. If the issue persists please seek help at ajdg.solutions/forums/forum/adrotate-for-wordpress/”

    AdRoatet version 395
    Database version: 65

    Newes WP version

    May you please help me on this?

    Thank you very much in advance and best regards,
    René

    #94907

    Arnan de Gans
    Badges:

    Please check your servers error_log file for errors.
    The error_log file can usually be found in your hosting dashboard.
    Anything mentioning AdRotate is interesting.

    #94947

    Thank you very much for your fast reply and your assistent on this. Highly appreciate it.

    Following the comment from the helpdesk of my serverprovider siteground:

    Below you can see the exact requests that is being generated when I try to add new advert:

    Code:
    82.118.240.146 – – [04/Jan/2020:07:38:04 -0600] “GET /wp-admin/admin.php?page=adrotate-ads&view=addnew HTTP/1.0″ 200 35767 “https://www.aftermarket-update.de/wp-admin/admin.php?page=adrotate-ads” “Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:71.0) Gecko/20100101 Firefox/71.0”

    As you can see from the status code (in bold) the requests was not blocked and it did not fail, it was successfully generated.

    The error log did not report any errors during the loading of the page and the browser console is also unable to detect any issues with the page. But i use the latest plugin version 5.6.2 and it seens you should have fixed the issue already here: https://ajdg.solutions/forums/topic/not-able-to-add-more-ads/

    What can we do?

    Regards,
    René

    #95028

    Arnan de Gans
    Badges:

    If WordPress generates an error like that there must be something logged somewhere.
    A mere access_log entry doesn’t tell you anything other than that the url/page was loaded – With or without error.

    What you describe indicates some kind of database issue – Or perhaps a permissions thing in WP.
    But without a proper error from the error_log I can’t see what’s going on exactly 🙁

    #95098

    Thank you very much for your assistence. I went back to my serverprovider and he recommend to forward follwing infromation to you:

    “I have enabled debug mode for your WordPress application:
    https://wordpress.org/support/article/debugging-in-wordpress/

    And the following errors appear upon adding new ads.
    Code:
    Notice: Die verwendete Konstruktor-Methode für WP_Widget in WP_Widget_Colorful_Tag_Cloud ist seit Version 4.3.0 veraltet! Verwende stattdessen
    __construct()
    . in /home/renh1002/public_html/wp-includes/functions.php on line 4716

    Notice: has_cap wurde mit einem Parameter oder Argument aufgerufen, der seit Version 2.0.0 veraltet ist! Die Verwendung von Benutzer-Levels ist veraltet. Verwende stattdessen Berechtigungen. in /home/renh1002/public_html/wp-includes/functions.php on line 4865

    Code:
    WordPress-Datenbank-Fehler: [Unknown column ‘os_ios’ in ‘field list’]
    INSERT INTO wp_adrotate (title, bannercode, thetime, updated, author, imagetype, image, tracker, show_everyone, desktop, mobile, tablet, os_ios, os_android, os_other, type, weight, autodelete, budget, crate, irate, cities, countries) VALUES (”, ”, ‘1578370954’, ‘1578370954’, ‘sgadmin’, ‘dropdown’, ”, ‘N’, ‘Y’, ‘Y’, ‘Y’, ‘Y’, ‘Y’, ‘Y’, ‘Y’, ’empty’, ‘6’, ‘N’, ‘0’, ‘0’, ‘0’, ‘a:0:{}’, ‘a:0:{}’)

    It appears that the plugin is not able to insert any data into the site’s database.

    I have checked the database using wp-cli(http://wp-cli.org/), but I didn’t find any issues with any of the database tables.
    Code:
    Success: Database checked.

    What I can suggest you is to forward this information to the plugin developers, as they should be able to further investigate this abnormal application behavior.

    I have disabled the error reporting once my testings were done.

    Is it possible to help me on this issue now? Thank you very much in advanced!

    Regards,
    René

    #95191

    Arnan de Gans
    Badges:

    The first bit, about the widget and functions.php are not from AdRotate – But you should look into those as well.

    The 2nd bit is indeed AdRotate and indicates the database is incomplete or not updated correctly.
    If you’ve been using a recent version of AdRotate it’s not likely an update issue.
    Sometimes when people move their site around parts of the database are not copied over.
    So start with making sure that your whole database is copied over – You can do so by simply comparing the original and new servers databases. All AdRotate data is stored in tables with the name AdRotate in it. And all settings are in wp_options, also marked with ‘adrotate’ in the name.

    Or, if you need help with this and want me to do it I can compare and fix up the database where required. My hourly fee is €45 (no vat). Usually something like this takes 1 hour.
    More on pricing here: https://ajdg.solutions/pricing/

    #95388

    Hello Arnan. Thanks for your help. I would very much like to accept your offer to fix this problem and happy to accept you hourly fee. How to progress furhter. My email is rene.herrmann@aftermarket-update.de
    Thank you in advance and best regards,
    René

    #95523

    Hello Arnan, How can we get together here? 🙂 Best regards,
    René

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

You may be interested in