Posted on Leave a comment

WooCommerce Plugins updated

Today WooCommerce 3.8 was released. Another immense list of changes and bugfixes that makes you wonder how the plugin worked in the first place. But a lot of good things have changed I guess…

I’ve been testing my WooCommerce plugins today and found them all compatible with both WordPress 5.3 and WooCommerce 3.8.
This includes; Woocommerce Paypal Surcharge, Woocommerce Stripe Surcharge, Woocommerce Single Page Checkout and Woocommerce Gateway Stats.

All 4 plugins are fully compatible with the latest and greatest from Automattic.
You can download the latest version of the plugin from your account if you bought one of them in the last 12 months.

If you don’t have these handy plugins yet. Get your copy here: